网络安全 当前位置:首页 > 计算机学习 > 网络知识 > 网络安全>正文

OSPF 区域 RIP EIGRP 注入推荐

【网络安全】 2018-01-26本文已影响

可以在R3 上的端口 f 1/0 上加上几句

(config-router)# ip summary-address eigrp 100 192.168.0.0 255.255.0.0

减少 R4 中的路由条目

因为路由器的路由ID为了好看,所以取了A类的 1.1.1.1~6.6.6.6 导致汇总不好汇总. 失败.呵呵.

r1>enFjo68学习网-学习教育资源分享平台
Password: Fjo68学习网-学习教育资源分享平台
r1#show runFjo68学习网-学习教育资源分享平台
Building configuration...

Current configuration : 871 bytesFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
version 12.3Fjo68学习网-学习教育资源分享平台
service timestamps debug datetime msecFjo68学习网-学习教育资源分享平台
service timestamps log datetime msecFjo68学习网-学习教育资源分享平台
no service password-encryptionFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
hostname r1?? //主机名Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
boot-start-markerFjo68学习网-学习教育资源分享平台
boot-end-markerFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
enable secret 5 $1$nFbz$rMMnSa5j4as5.FCiB0BlE0? //加密口令Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no aaa new-modelFjo68学习网-学习教育资源分享平台
ip subnet-zero??? // 可使用子网0Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no ip domain lookup???? // no 掉 name-serverFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip cefFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface Loopback0??????? //本地回环0??????????? Fjo68学习网-学习教育资源分享平台
?ip address 192.168.50.1 255.255.255.255Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface Loopback1??????? //本地回环1 (虚拟出来测试用的)Fjo68学习网-学习教育资源分享平台
?ip address 192.168.30.1 255.255.255.248Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet0/0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.30.9 255.255.255.248Fjo68学习网-学习教育资源分享平台
?duplex half

interface FastEthernet1/0Fjo68学习网-学习教育资源分享平台
?no ip addressFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router ospf 1???????? // ospf 进程 1Fjo68学习网-学习教育资源分享平台
?log-adjacency-changesFjo68学习网-学习教育资源分享平台
?area 1 stub????????? // stub 区域, 在ABR 设置 no-summary , 变成 totally stubFjo68学习网-学习教育资源分享平台
?network 192.168.30.0 0.0.0.255 area 1?? // 宣告Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip classless??????????? // 无类路由查询Fjo68学习网-学习教育资源分享平台
no ip http serverFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
gatekeeperFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
line con 0 Fjo68学习网-学习教育资源分享平台
?stopbits 1Fjo68学习网-学习教育资源分享平台
line aux 0Fjo68学习网-学习教育资源分享平台
line vty 0 4???????? // 开启 telnetFjo68学习网-学习教育资源分享平台
?password 123??????? // telnet 密码Fjo68学习网-学习教育资源分享平台
?loginFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
end

r1#show ip ospf database database-summary

??????????? OSPF Router with ID (192.168.50.1) (Process ID 1)

Area 1 database summary?????????????????? Fjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Subtotal????? 4??????? 0??????? 0??????

Process 1 database summary??????????????? Fjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-5 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque AS???? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Total???????? 4??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
r1#show ip routeFjo68学习网-学习教育资源分享平台
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPFjo68学习网-学习教育资源分享平台
?????? D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area Fjo68学习网-学习教育资源分享平台
?????? N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2Fjo68学习网-学习教育资源分享平台
?????? E1 - OSPF external type 1, E2 - OSPF external type 2Fjo68学习网-学习教育资源分享平台
?????? i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2Fjo68学习网-学习教育资源分享平台
?????? ia - IS-IS inter area, * - candidate default, U - per-user static routeFjo68学习网-学习教育资源分享平台
?????? o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.30.10 to network 0.0.0.0

???? 192.168.30.0/29 is subnetted, 2 subnetsFjo68学习网-学习教育资源分享平台
C?????? 192.168.30.0 is directly connected, Loopback1Fjo68学习网-学习教育资源分享平台
C?????? 192.168.30.8 is directly connected, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
?????? 192.168.50.0/32 is subnetted, 2 subnetsFjo68学习网-学习教育资源分享平台
O?????? 192.168.50.2 [110/2] via 192.168.30.10, 00:22:37, FastEthernet0/0? Fjo68学习网-学习教育资源分享平台
C?????? 192.168.50.1 is directly connected, Loopback0Fjo68学习网-学习教育资源分享平台
O*IA 0.0.0.0/0 [110/2] via 192.168.30.10, 00:22:05, FastEthernet0/0?? // 3 类缺省 , 优化 r1 的路由表

r1#192.168.30.10?????????????????? // telnet 到 r2Fjo68学习网-学习教育资源分享平台
Trying 192.168.30.10 ... Open

Fjo68学习网-学习教育资源分享平台
User Access Verification

Password: Fjo68学习网-学习教育资源分享平台
r2>enFjo68学习网-学习教育资源分享平台
Password: Fjo68学习网-学习教育资源分享平台
r2#show runFjo68学习网-学习教育资源分享平台
Building configuration...

Current configuration : 875 bytesFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
version 12.3Fjo68学习网-学习教育资源分享平台
service timestamps debug datetime msecFjo68学习网-学习教育资源分享平台
service timestamps log datetime msecFjo68学习网-学习教育资源分享平台
no service password-encryptionFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
hostname r2?????? // 主机名 r2Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
boot-start-markerFjo68学习网-学习教育资源分享平台
boot-end-markerFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
enable secret 5 $1$Hfq3$r7mcZQStWzg7BVqq.26pO0?? // 加密口令Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no aaa new-modelFjo68学习网-学习教育资源分享平台
ip subnet-zero? //使用子网0Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no ip domain lookup? // 关闭域名解析Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip cefFjo68学习网-学习教育资源分享平台
!

!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface Loopback0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.50.2 255.255.255.255Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet0/0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.30.10 255.255.255.248Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet1/0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.20.1 255.255.255.252Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router ospf 1Fjo68学习网-学习教育资源分享平台
?log-adjacency-changesFjo68学习网-学习教育资源分享平台
?area 1 stub no-summary?????????????????? // ABR , stub 区域所有router必须都配置为stub, 在ABR 配置 no-summary,使区域称为 totally stub areaFjo68学习网-学习教育资源分享平台
?network 192.168.20.0 0.0.0.255 area 0??? // 宣告Fjo68学习网-学习教育资源分享平台
?network 192.168.30.0 0.0.0.255 area 1??? // 宣告Fjo68学习网-学习教育资源分享平台
?network 192.168.50.2 0.0.0.0 area 1????? // 宣告Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip classless????? // 无类路由查询Fjo68学习网-学习教育资源分享平台
no ip http serverFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
gatekeeperFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
line con 0Fjo68学习网-学习教育资源分享平台
?stopbits 1Fjo68学习网-学习教育资源分享平台
line aux 0Fjo68学习网-学习教育资源分享平台
line vty 0 4???? // 开启 telnetFjo68学习网-学习教育资源分享平台
?password 123??? // telnet 密码Fjo68学习网-学习教育资源分享平台
?loginFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
end

r2#show ip ospf database database-summary

??????????? OSPF Router with ID (192.168.50.2) (Process ID 1)

Area 0 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 2??????? 0??????? 0??????? Fjo68学习网-学习教育资源分享平台
? Network?????? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 6??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Subtotal????? 9??????? 0??????? 0??????

Area 1 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Subtotal????? 4??????? 0??????? 0??????

Process 1 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 4??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 2??????? 0??????? 0????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 7??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-5 Ext??? 5??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque AS???? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Total???????? 18?????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
r2#show ip routeFjo68学习网-学习教育资源分享平台
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPFjo68学习网-学习教育资源分享平台
?????? D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area Fjo68学习网-学习教育资源分享平台
?????? N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2Fjo68学习网-学习教育资源分享平台
?????? E1 - OSPF external type 1, E2 - OSPF external type 2Fjo68学习网-学习教育资源分享平台
?????? i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2Fjo68学习网-学习教育资源分享平台
?????? ia - IS-IS inter area, * - candidate default, U - per-user static routeFjo68学习网-学习教育资源分享平台
?????? o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

???? 192.168.30.0/24 is variably subnetted, 2 subnets, 2 masksFjo68学习网-学习教育资源分享平台
O?????? 192.168.30.1/32 [110/2] via 192.168.30.9, 00:22:31, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
C?????? 192.168.30.8/29 is directly connected, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 192.168.10.0/27 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
O IA??? 192.168.10.0 [110/2] via 192.168.20.2, 00:17:54, FastEthernet1/0Fjo68学习网-学习教育资源分享平台
???? 172.19.0.0/25 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
O E2??? 172.19.35.0 [110/10] via 192.168.20.2, 00:17:49, FastEthernet1/0????????? Fjo68学习网-学习教育资源分享平台
???? 192.168.20.0/30 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
C?????? 192.168.20.0 is directly connected, FastEthernet1/0Fjo68学习网-学习教育资源分享平台
???? 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masksFjo68学习网-学习教育资源分享平台
O E2??? 10.2.2.0/24 [110/10] via 192.168.20.2, 00:17:49, FastEthernet1/0????????? Fjo68学习网-学习教育资源分享平台
O E2??? 10.1.1.0/29 [110/10] via 192.168.20.2, 00:17:49, FastEthernet1/0????????? Fjo68学习网-学习教育资源分享平台
???? 192.168.50.0/24 is variably subnetted, 6 subnets, 2 masksFjo68学习网-学习教育资源分享平台
C?????? 192.168.50.2/32 is directly connected, Loopback0Fjo68学习网-学习教育资源分享平台
O?????? 192.168.50.3/32 [110/2] via 192.168.20.2, 00:22:32, FastEthernet1/0Fjo68学习网-学习教育资源分享平台
O E2??? 192.168.50.0/24 [110/10] via 192.168.20.2, 00:02:00, FastEthernet1/0Fjo68学习网-学习教育资源分享平台
O?????? 192.168.50.1/32 [110/2] via 192.168.30.9, 00:22:32, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
O E2??? 192.168.50.4/32 [110/10] via 192.168.20.2, 00:17:50, FastEthernet1/0????? Fjo68学习网-学习教育资源分享平台
O IA??? 192.168.50.5/32 [110/3] via 192.168.20.2, 00:17:50, FastEthernet1/0

r2#192.168.20.2??????????????????? // telnet 到 r 3Fjo68学习网-学习教育资源分享平台
Trying 192.168.20.2 ... Open

Fjo68学习网-学习教育资源分享平台
User Access Verification

Password: Fjo68学习网-学习教育资源分享平台
r3>enFjo68学习网-学习教育资源分享平台
Password: Fjo68学习网-学习教育资源分享平台
r3#show runFjo68学习网-学习教育资源分享平台
Building configuration...

Current configuration : 1143 bytesFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
version 12.3Fjo68学习网-学习教育资源分享平台
service timestamps debug datetime msecFjo68学习网-学习教育资源分享平台
service timestamps log datetime msecFjo68学习网-学习教育资源分享平台
no service password-encryptionFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
hostname r3Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
boot-start-markerFjo68学习网-学习教育资源分享平台
boot-end-markerFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
enable secret 5 $1$fLpG$ugh.ML9BEMnh.jlccxY9S1Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no aaa new-modelFjo68学习网-学习教育资源分享平台
ip subnet-zeroFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no ip domain lookupFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip cefFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface Loopback0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.50.3 255.255.255.255Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet0/0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.20.2 255.255.255.252Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet1/0Fjo68学习网-学习教育资源分享平台
?ip address 10.1.1.5 255.255.255.248Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet2/0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.10.1 255.255.255.224Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router eigrp 100??????????????????????????????????? // 进程号必须相同Fjo68学习网-学习教育资源分享平台
?redistribute ospf 1 metric 100000 100 255 5 1500?? // 把 ospf 注入 ergip? 带宽 时延 可靠性 负载 MTUFjo68学习网-学习教育资源分享平台
?network 10.0.0.0?????????? // 宣告Fjo68学习网-学习教育资源分享平台
?auto-summaryFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router ospf 1Fjo68学习网-学习教育资源分享平台
?log-adjacency-changesFjo68学习网-学习教育资源分享平台
?area 2 nssa no-redistribution default-information-originate no-summary?? // 这里其实no-summary 是不用再default-information-originate 的,但是变相看出r 5的缺Fjo68学习网-学习教育资源分享平台
???????????????????????????????????????????????????????????????????????????? 省路由变成了 3类, 7类其实只有再没有 no-summary 才启效, 否则屏蔽在 3类下.Fjo68学习网-学习教育资源分享平台
?redistribute eigrp 100 metric 10 subnets???????????????????????????????? // 把 eigrp 注入 ospf????????????????????????? Fjo68学习网-学习教育资源分享平台
?network 192.168.10.0 0.0.0.255 area 2??????????????????????????????????? // 宣告Fjo68学习网-学习教育资源分享平台
?network 192.168.20.0 0.0.0.255 area 0??????????????????????????????????? // 宣告Fjo68学习网-学习教育资源分享平台
?network 192.168.50.3 0.0.0.0 area 0????????????????????????????????????? // 宣告Fjo68学习网-学习教育资源分享平台
! Fjo68学习网-学习教育资源分享平台
ip classlessFjo68学习网-学习教育资源分享平台
no ip http serverFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
gatekeeperFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
line con 0Fjo68学习网-学习教育资源分享平台
?stopbits 1Fjo68学习网-学习教育资源分享平台
line aux 0Fjo68学习网-学习教育资源分享平台
line vty 0 4Fjo68学习网-学习教育资源分享平台
?password 123Fjo68学习网-学习教育资源分享平台
?loginFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
end

r3#show ip ospf database database-summary

??????????? OSPF Router with ID (192.168.50.3) (Process ID 1)

Area 0 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 6??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Subtotal????? 9??????? 0??????? 0??????

Area 2 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 3??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Subtotal????? 7??????? 0??????? 0??????

Process 1 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 4??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 7??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 3??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-5 Ext??? 5??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque AS???? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Total???????? 21?????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
r3#show ip routeFjo68学习网-学习教育资源分享平台
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPFjo68学习网-学习教育资源分享平台
?????? D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area Fjo68学习网-学习教育资源分享平台
?????? N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2Fjo68学习网-学习教育资源分享平台
?????? E1 - OSPF external type 1, E2 - OSPF external type 2Fjo68学习网-学习教育资源分享平台
?????? i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2Fjo68学习网-学习教育资源分享平台
?????? ia - IS-IS inter area, * - candidate default, U - per-user static routeFjo68学习网-学习教育资源分享平台
?????? o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

???? 192.168.30.0/24 is variably subnetted, 2 subnets, 2 masksFjo68学习网-学习教育资源分享平台
O IA??? 192.168.30.1/32 [110/3] via 192.168.20.1, 00:14:06, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
O IA??? 192.168.30.8/29 [110/2] via 192.168.20.1, 00:14:06, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 192.168.10.0/27 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
C?????? 192.168.10.0 is directly connected, FastEthernet2/0Fjo68学习网-学习教育资源分享平台
???? 172.19.0.0/25 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
O N2??? 172.19.35.0 [110/10] via 192.168.10.2, 00:14:06, FastEthernet2/0? // LSA 7 类 从 RIP 泛洪在 nssa区域获得Fjo68学习网-学习教育资源分享平台
???? 192.168.20.0/30 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
C?????? 192.168.20.0 is directly connected, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masksFjo68学习网-学习教育资源分享平台
D?????? 10.2.2.0/24 [90/156160] via 10.1.1.6, 00:51:36, FastEthernet1/0Fjo68学习网-学习教育资源分享平台
C?????? 10.1.1.0/29 is directly connected, FastEthernet1/0Fjo68学习网-学习教育资源分享平台
???? 192.168.50.0/24 is variably subnetted, 6 subnets, 2 masksFjo68学习网-学习教育资源分享平台
O IA??? 192.168.50.2/32 [110/2] via 192.168.20.1, 00:14:07, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
C?????? 192.168.50.3/32 is directly connected, Loopback0Fjo68学习网-学习教育资源分享平台
O N2??? 192.168.50.0/24 [110/10] via 192.168.10.2, 00:02:20, FastEthernet2/0? // LSA 7 类 从 RIP 泛洪在 nssa区域获得Fjo68学习网-学习教育资源分享平台
O IA??? 192.168.50.1/32 [110/3] via 192.168.20.1, 00:14:07, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
D?????? 192.168.50.4/32 [90/156160] via 10.1.1.6, 00:51:37, FastEthernet1/0?? // eigrp 注入获得Fjo68学习网-学习教育资源分享平台
O?????? 192.168.50.5/32 [110/2] via 192.168.10.2, 00:14:07, FastEthernet2/0

Fjo68学习网-学习教育资源分享平台
r3#10.1.1.6????????????????????????? //telnet 到 r 4Fjo68学习网-学习教育资源分享平台
Trying 10.1.1.6 ... Open

Fjo68学习网-学习教育资源分享平台
User Access Verification

Password: Fjo68学习网-学习教育资源分享平台
r4>enFjo68学习网-学习教育资源分享平台
Password: Fjo68学习网-学习教育资源分享平台
r4#show runFjo68学习网-学习教育资源分享平台
Building configuration...

Current configuration : 861 bytesFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
version 12.3Fjo68学习网-学习教育资源分享平台
service timestamps debug datetime msecFjo68学习网-学习教育资源分享平台
service timestamps log datetime msecFjo68学习网-学习教育资源分享平台
no service password-encryptionFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
hostname r4Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
boot-start-markerFjo68学习网-学习教育资源分享平台
boot-end-markerFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
enable secret 5 $1$KN2Y$79ZsH8DmO6F8LDMoKYk5p.Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no aaa new-modelFjo68学习网-学习教育资源分享平台
ip subnet-zeroFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no ip domain lookupFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip cefFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface Loopback0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.50.4 255.255.255.255Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface Loopback1Fjo68学习网-学习教育资源分享平台
?ip address 10.2.2.2 255.255.255.0Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet0/0Fjo68学习网-学习教育资源分享平台
?ip address 10.1.1.6 255.255.255.252Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet1/0Fjo68学习网-学习教育资源分享平台
?no ip addressFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router eigrp 100????? //启动 eigrp 进程 ,进程号于 r 3 相同Fjo68学习网-学习教育资源分享平台
?network 10.0.0.0????? // 宣告Fjo68学习网-学习教育资源分享平台
?network 192.168.50.0? // 宣告Fjo68学习网-学习教育资源分享平台
?no auto-summaryFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router ospf 1Fjo68学习网-学习教育资源分享平台
?log-adjacency-changesFjo68学习网-学习教育资源分享平台
?area 2 nssaFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip classlessFjo68学习网-学习教育资源分享平台
no ip http serverFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
gatekeeperFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
line con 0Fjo68学习网-学习教育资源分享平台
?stopbits 1Fjo68学习网-学习教育资源分享平台
line aux 0Fjo68学习网-学习教育资源分享平台
line vty 0 4Fjo68学习网-学习教育资源分享平台
?password 123Fjo68学习网-学习教育资源分享平台
?loginFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
end

r4#show ip ospf database DAtabase-summary

??????????? OSPF Router with ID (192.168.50.4) (Process ID 1)

Area 2 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Subtotal????? 0??????? 0??????? 0??????

Process 1 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-5 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque AS???? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Total???????? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
r4#show ip routeFjo68学习网-学习教育资源分享平台
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPFjo68学习网-学习教育资源分享平台
?????? D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area Fjo68学习网-学习教育资源分享平台
?????? N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2Fjo68学习网-学习教育资源分享平台
?????? E1 - OSPF external type 1, E2 - OSPF external type 2Fjo68学习网-学习教育资源分享平台
?????? i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2Fjo68学习网-学习教育资源分享平台
?????? ia - IS-IS inter area, * - candidate default, U - per-user static routeFjo68学习网-学习教育资源分享平台
?????? o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

???? 192.168.30.0/24 is variably subnetted, 2 subnets, 2 masksFjo68学习网-学习教育资源分享平台
D EX??? 192.168.30.1/32 [170/53760] via 10.1.1.5, 00:28:28, FastEthernet0/0??? // eigrp 从 ospf 注入的 Fjo68学习网-学习教育资源分享平台
D EX??? 192.168.30.8/29 [170/53760] via 10.1.1.5, 00:28:33, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 192.168.10.0/27 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
D EX??? 192.168.10.0 [170/53760] via 10.1.1.5, 00:50:41, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 172.19.0.0/25 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
D EX??? 172.19.35.0 [170/53760] via 10.1.1.5, 00:19:21, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 192.168.20.0/30 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
D EX??? 192.168.20.0 [170/53760] via 10.1.1.5, 00:50:41, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masksFjo68学习网-学习教育资源分享平台
C?????? 10.2.2.0/24 is directly connected, Loopback1Fjo68学习网-学习教育资源分享平台
C?????? 10.1.1.4/30 is directly connected, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 192.168.50.0/32 is subnetted, 5 subnetsFjo68学习网-学习教育资源分享平台
D EX??? 192.168.50.2 [170/53760] via 10.1.1.5, 00:50:41, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
D EX??? 192.168.50.3 [170/53760] via 10.1.1.5, 00:49:42, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
D EX??? 192.168.50.1 [170/53760] via 10.1.1.5, 00:28:29, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
C?????? 192.168.50.4 is directly connected, Loopback0Fjo68学习网-学习教育资源分享平台
D EX??? 192.168.50.5 [170/53760] via 10.1.1.5, 00:19:22, FastEthernet0/0

r4#192.168.10.2???????????????????? // telnet 到 r 5Fjo68学习网-学习教育资源分享平台
Trying 192.168.10.2 ... Open

Fjo68学习网-学习教育资源分享平台
User Access Verification

Password: Fjo68学习网-学习教育资源分享平台
r5>enFjo68学习网-学习教育资源分享平台
Password: Fjo68学习网-学习教育资源分享平台
r5#show runFjo68学习网-学习教育资源分享平台
Building configuration...

Current configuration : 923 bytesFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
version 12.3Fjo68学习网-学习教育资源分享平台
service timestamps debug datetime msecFjo68学习网-学习教育资源分享平台
service timestamps log datetime msecFjo68学习网-学习教育资源分享平台
no service password-encryptionFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
hostname r5Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
boot-start-markerFjo68学习网-学习教育资源分享平台
boot-end-markerFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
enable secret 5 $1$pXvU$0p.wge6o4efg7WtWElv/e1Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no aaa new-modelFjo68学习网-学习教育资源分享平台
ip subnet-zeroFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no ip domain lookupFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip cefFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface Loopback0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.50.5 255.255.255.255Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet0/0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.10.2 255.255.255.224Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet1/0Fjo68学习网-学习教育资源分享平台
?ip address 172.19.35.15 255.255.255.128Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router ospf 1Fjo68学习网-学习教育资源分享平台
?log-adjacency-changesFjo68学习网-学习教育资源分享平台
?area 2 nssa??????????????????????????? // nssa 区域内的路由器必须统一设置为nssa 区域 Fjo68学习网-学习教育资源分享平台
?redistribute rip metric 10 subnets???? // 注入 rip 信息Fjo68学习网-学习教育资源分享平台
?network 192.168.10.0 0.0.0.31 area 2?? // 宣告Fjo68学习网-学习教育资源分享平台
?network 192.168.50.5 0.0.0.0 area 2??? // 宣告Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router ripFjo68学习网-学习教育资源分享平台
?redistribute ospf 1 metric 10????????? // 给rip 注入 ospf 信息Fjo68学习网-学习教育资源分享平台
?network 172.19.0.0???????????????????? // 宣告Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip classlessFjo68学习网-学习教育资源分享平台
no ip http serverFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
gatekeeperFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
line con 0Fjo68学习网-学习教育资源分享平台
?stopbits 1Fjo68学习网-学习教育资源分享平台
line aux 0Fjo68学习网-学习教育资源分享平台
line vty 0 4Fjo68学习网-学习教育资源分享平台
?password 123Fjo68学习网-学习教育资源分享平台
?loginFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
end

r5#show ip ospf database database-summary

??????????? OSPF Router with ID (192.168.50.5) (Process ID 1)

Area 2 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Subtotal????? 6??????? 0??????? 0??????

Process 1 database summaryFjo68学习网-学习教育资源分享平台
? LSA Type????? Count??? Delete?? MaxageFjo68学习网-学习教育资源分享平台
? Router??????? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Network?????? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary Net?? 1??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Summary ASBR? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-7 Ext??? 2??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Link?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque Area?? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Type-5 Ext??? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Opaque AS???? 0??????? 0??????? 0?????? Fjo68学习网-学习教育资源分享平台
? Total???????? 6??????? 0??????? 0??????

r5#show ip route Fjo68学习网-学习教育资源分享平台
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPFjo68学习网-学习教育资源分享平台
?????? D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area Fjo68学习网-学习教育资源分享平台
?????? N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2Fjo68学习网-学习教育资源分享平台
?????? E1 - OSPF external type 1, E2 - OSPF external type 2Fjo68学习网-学习教育资源分享平台
?????? i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2Fjo68学习网-学习教育资源分享平台
?????? ia - IS-IS inter area, * - candidate default, U - per-user static routeFjo68学习网-学习教育资源分享平台
?????? o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

???? 192.168.10.0/27 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
C?????? 192.168.10.0 is directly connected, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 172.19.0.0/25 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
C?????? 172.19.35.0 is directly connected, FastEthernet1/0Fjo68学习网-学习教育资源分享平台
???? 192.168.50.0/32 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
C?????? 192.168.50.5 is directly connected, Loopback0Fjo68学习网-学习教育资源分享平台
O*IA 0.0.0.0/0 [110/2] via 192.168.10.1, 00:16:05, FastEthernet0/0??? // 这里体现了 r3 作为 ASBR/ABR ,输入 no-summary no-redistribution 的功效

r5#172.19.35.1Fjo68学习网-学习教育资源分享平台
Trying 172.19.35.1 ... Open

Fjo68学习网-学习教育资源分享平台
User Access Verification

Password: Fjo68学习网-学习教育资源分享平台
r6>enFjo68学习网-学习教育资源分享平台
Password: Fjo68学习网-学习教育资源分享平台
r6#show runFjo68学习网-学习教育资源分享平台
Building configuration...

Current configuration : 732 bytesFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
version 12.3Fjo68学习网-学习教育资源分享平台
service timestamps debug datetime msecFjo68学习网-学习教育资源分享平台
service timestamps log datetime msecFjo68学习网-学习教育资源分享平台
no service password-encryptionFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
hostname r6Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
boot-start-markerFjo68学习网-学习教育资源分享平台
boot-end-markerFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
enable secret 5 $1$MF75$hdDRi34xb6xvhNW4nvbn6.Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no aaa new-modelFjo68学习网-学习教育资源分享平台
ip subnet-zeroFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
no ip domain lookupFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
ip cefFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface Loopback0Fjo68学习网-学习教育资源分享平台
?ip address 192.168.50.6 255.255.255.0Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet0/0Fjo68学习网-学习教育资源分享平台
?ip address 172.19.35.1 255.255.255.128Fjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
interface FastEthernet1/0Fjo68学习网-学习教育资源分享平台
?no ip addressFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
?duplex halfFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
router rip????????????? //? 开启 rip 进程Fjo68学习网-学习教育资源分享平台
?network 172.19.0.0???? //? 宣告Fjo68学习网-学习教育资源分享平台
?network 192.168.50.0?? //? 宣告Fjo68学习网-学习教育资源分享平台
! Fjo68学习网-学习教育资源分享平台
ip classlessFjo68学习网-学习教育资源分享平台
no ip http serverFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
gatekeeperFjo68学习网-学习教育资源分享平台
?shutdownFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
line con 0Fjo68学习网-学习教育资源分享平台
stopbits 1Fjo68学习网-学习教育资源分享平台
line aux 0Fjo68学习网-学习教育资源分享平台
line vty 0 4Fjo68学习网-学习教育资源分享平台
?password 123Fjo68学习网-学习教育资源分享平台
?loginFjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
!Fjo68学习网-学习教育资源分享平台
end

Fjo68学习网-学习教育资源分享平台
r6#show ip ospf database? database-summary

r6#show ip routeFjo68学习网-学习教育资源分享平台
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPFjo68学习网-学习教育资源分享平台
?????? D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area Fjo68学习网-学习教育资源分享平台
?????? N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2Fjo68学习网-学习教育资源分享平台
?????? E1 - OSPF external type 1, E2 - OSPF external type 2Fjo68学习网-学习教育资源分享平台
?????? i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2Fjo68学习网-学习教育资源分享平台
?????? ia - IS-IS inter area, * - candidate default, U - per-user static routeFjo68学习网-学习教育资源分享平台
?????? o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.19.35.15 to network 0.0.0.0

R??? 192.168.10.0/24 [120/10] via 172.19.35.15, 00:00:04, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
???? 172.19.0.0/25 is subnetted, 1 subnetsFjo68学习网-学习教育资源分享平台
C?????? 172.19.35.0 is directly connected, FastEthernet0/0Fjo68学习网-学习教育资源分享平台
C??? 192.168.50.0/24 is directly connected, Loopback0Fjo68学习网-学习教育资源分享平台
R*?? 0.0.0.0/0 [120/10] via 172.19.35.15, 00:00:04, FastEthernet0/0????????? // r 5 的默认在注入时也就注入了rip

r6#ping 10.2.2.2??????????????? //测试到 eigrp

Type escape sequence to abort.Fjo68学习网-学习教育资源分享平台
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:Fjo68学习网-学习教育资源分享平台
!!!!!Fjo68学习网-学习教育资源分享平台
Success rate is 100 percent (5/5), round-trip min/avg/max = 260/268/296 msFjo68学习网-学习教育资源分享平台
r6#ping 192.168.10.1??????????? // 测试到远端

Type escape sequence to abort.Fjo68学习网-学习教育资源分享平台
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:Fjo68学习网-学习教育资源分享平台
!!!!!Fjo68学习网-学习教育资源分享平台
Success rate is 100 percent (5/5), round-trip min/avg/max = 144/177/200 msFjo68学习网-学习教育资源分享平台
版权声明:原创作品,如需转载,请与作者联系。否则将追究法律责任

本站所有资源均来自于68学习网蜘蛛爬取结果,如您发现侵权、违法、存在不和谐内容,告知本站一律删除

本站不以盈利为目的,全站资源仅供学习爱好使用。本站站长邮箱:luo689up@foxmail.com

备案号:闽ICP备15018334号-2

©68学习网  2016-2017版权所有     站点地图

回到顶部