网络安全 当前位置:首页 > 计算机学习 > 网络知识 > 网络安全>正文

NAT转换实验过程详解推荐

【网络安全】 2018-01-26本文已影响
原创作品,未经作者授权,严禁转载。? 1Jo68学习网-学习教育资源分享平台
作者:网络白领????? 实验指导:鑫飘雪
?
实验拓扑图:点击在新窗口查看全图环境配置说明:1Jo68学习网-学习教育资源分享平台
1、将R3的Fa0/0接口的IP设为192.168.0.3/24,关闭路由功能,模拟PC使用;1Jo68学习网-学习教育资源分享平台
2、将R2的Fa0/0接口的IP设为192.168.2.2/24,S1/2接口的IP设为202.96.134.2/24;1Jo68学习网-学习教育资源分享平台
3、将R1的Fa0/0接口的IP设为192.168.0.1/24,S1/2接口的IP设为202.96.134.1/24 。?实验结果要求:在R1上做NAT转换,使R3能够ping通R2的S1/2和Fa0/0接口。?R1的配置清单:1Jo68学习网-学习教育资源分享平台
1、分别为R1的Fa0/0 、S1/2接口设置IP,并指定内部、外部接口:1Jo68学习网-学习教育资源分享平台
R1(config)#int fa0/01Jo68学习网-学习教育资源分享平台
R1(config-if)#speed 1001Jo68学习网-学习教育资源分享平台
R1(config-if)#duplex full1Jo68学习网-学习教育资源分享平台
R1(config-if)#ip add 192.168.0.1 255.255.255.01Jo68学习网-学习教育资源分享平台
R1(config-if)#ip nat inside? //指定该接口为内部接口1Jo68学习网-学习教育资源分享平台
R1(config-if)#no shut1Jo68学习网-学习教育资源分享平台
R1(config-if)#exitR1(config)#int s1/21Jo68学习网-学习教育资源分享平台
R1(config-if)#ip add 202.96.134.1 255.255.255.01Jo68学习网-学习教育资源分享平台
R1(config-if)#ip nat outside? //指定该接口为外部接口1Jo68学习网-学习教育资源分享平台
R1(config-if)#no shut1Jo68学习网-学习教育资源分享平台
R1(config-if)#exit1Jo68学习网-学习教育资源分享平台
2、在R1上做NAT转换:1Jo68学习网-学习教育资源分享平台
R1(config)#access-list 1 permit 192.168.0.0 0.0.0.255? //配置访问控制列表,定义一组精确流量1Jo68学习网-学习教育资源分享平台
R1(config)#ip nat inside source list 1 interface serial 1/2? //定义需要转换内部地址的接口?R2的配置清单:1Jo68学习网-学习教育资源分享平台
R2(config)#int fa0/01Jo68学习网-学习教育资源分享平台
R2(config-if)#speed 1001Jo68学习网-学习教育资源分享平台
R2(config-if)#duplex full1Jo68学习网-学习教育资源分享平台
R2(config-if)#ip add 192.168.2.2 255.255.255.01Jo68学习网-学习教育资源分享平台
R2(config-if)#no shut1Jo68学习网-学习教育资源分享平台
R2(config-if)#exitR2(config)#int s1/21Jo68学习网-学习教育资源分享平台
R2(config-if)#ip add 202.96.134.2 255.255.255.01Jo68学习网-学习教育资源分享平台
R2(config-if)#no shut1Jo68学习网-学习教育资源分享平台
R2(config-if)#exit?R3的配置清单:1Jo68学习网-学习教育资源分享平台
R3(config)#no ip routing? //关闭路由功能,模拟PC使用1Jo68学习网-学习教育资源分享平台
R3(config)#ip default-gateway 192.168.0.1? //设置默认网关1Jo68学习网-学习教育资源分享平台
R3(config)#in fa0/01Jo68学习网-学习教育资源分享平台
R3(config-if)#speed 1001Jo68学习网-学习教育资源分享平台
R3(config-if)#duplex full1Jo68学习网-学习教育资源分享平台
R3(config-if)#ip add 192.168.0.3 255.255.255.01Jo68学习网-学习教育资源分享平台
R3(config-if)#no shut?SW1的配置清单:1Jo68学习网-学习教育资源分享平台
SW1(config)#int fa1/131Jo68学习网-学习教育资源分享平台
SW1(config-if)#speed 1001Jo68学习网-学习教育资源分享平台
SW1(config-if)#duplex full1Jo68学习网-学习教育资源分享平台
SW1(config-if)#no shut1Jo68学习网-学习教育资源分享平台
SW1(config-if)#exitSW1(config)#int fa1/141Jo68学习网-学习教育资源分享平台
SW1(config-if)#speed 1001Jo68学习网-学习教育资源分享平台
SW1(config-if)#duplex full1Jo68学习网-学习教育资源分享平台
SW1(config-if)#no shut1Jo68学习网-学习教育资源分享平台
SW1(config-if)#exitSW1(config)#int fa1/151Jo68学习网-学习教育资源分享平台
SW1(config-if)#speed 1001Jo68学习网-学习教育资源分享平台
SW1(config-if)#duplex full1Jo68学习网-学习教育资源分享平台
SW1(config-if)#no shut1Jo68学习网-学习教育资源分享平台
SW1(config-if)#exit?配置完成了,我们来用R3 ping R2 的S1/2接口(202.96.134.2):1Jo68学习网-学习教育资源分享平台
R1#ping 202.96.134.2Type escape sequence to abort.1Jo68学习网-学习教育资源分享平台
Sending 5, 100-byte ICMP Echos to 202.96.134.2, timeout is 2 seconds:1Jo68学习网-学习教育资源分享平台
!!!!!1Jo68学习网-学习教育资源分享平台
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/164/436 ms?R1#show ip nat translations 1Jo68学习网-学习教育资源分享平台
Pro Inside global????? Inside local?????? Outside local????? Outside global1Jo68学习网-学习教育资源分享平台
icmp 202.96.134.1:5??? 192.168.0.3:5????? 202.96.134.2:5???? 202.96.134.2:51Jo68学习网-学习教育资源分享平台
结果显示ping 通了,说明我们的NAT转换是成功的,这样就实现了实验结果要求1,上面演示的是基于接口动态获取外部全局IP地址,适用于像ADSL这样的动态分配外网IP地址的情况。如果有多个外部全局IP地址,我们就要使用基于地址池的方法,那么R1的第二步配置过程就是这样的:?1、创建访问控制列表:1Jo68学习网-学习教育资源分享平台
R1(config)#access-list 1 permit 192.168.0.0 0.0.0.255? //配置访问控制列表,定义一组精确流量1Jo68学习网-学习教育资源分享平台
2、创建地址池:1Jo68学习网-学习教育资源分享平台
R1(config)#ip nat pool psx 202.96.134.1 202.96.134.1 netmask 255.255.255.01Jo68学习网-学习教育资源分享平台
3、应用地址池:1Jo68学习网-学习教育资源分享平台
R1(config)#ip nat inside source list 1 pool psx overload?测试结果:1Jo68学习网-学习教育资源分享平台
R1#ping 202.96.134.2Type escape sequence to abort.1Jo68学习网-学习教育资源分享平台
Sending 5, 100-byte ICMP Echos to 202.96.134.2, timeout is 2 seconds:1Jo68学习网-学习教育资源分享平台
!!!!!1Jo68学习网-学习教育资源分享平台
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/61/68 ms?R1#show ip nat translations 1Jo68学习网-学习教育资源分享平台
Pro Inside global????? Inside local?????? Outside local????? Outside global1Jo68学习网-学习教育资源分享平台
icmp 202.96.134.1:7??? 192.168.0.3:7????? 202.96.134.2:7???? 202.96.134.2:7?我们再使用telnet命令来测试从R3telnet到R2的S1/2接口:R3#telnet 202.96.134.21Jo68学习网-学习教育资源分享平台
Trying 202.96.134.2 ... Open1Jo68学习网-学习教育资源分享平台
User Access VerificationPassword: 1Jo68学习网-学习教育资源分享平台
R2>en1Jo68学习网-学习教育资源分享平台
Password: 1Jo68学习网-学习教育资源分享平台
R2#?R1#show ip nat tran1Jo68学习网-学习教育资源分享平台
Pro Inside global????? Inside local?????? Outside local????? Outside global1Jo68学习网-学习教育资源分享平台
tcp 202.96.134.1:18932 192.168.0.3:18932? 202.96.134.2:23??? 202.96.134.2:23?到这里我们只完成了R3可以ping通R2的S1/2接口的实验,但R3如何ping通R2的Fa0/0接口呢?分析发现,R1的路由表中根本没有192.168.2.0这个网段,数据包就被丢弃了,所以我们只需要在R1上增加一条路由就OK了:1Jo68学习网-学习教育资源分享平台
R1(config)#ip route 192.168.2.0 255.255.255.0 202.96.134.2 1Jo68学习网-学习教育资源分享平台
?//增加192.168.2.0网段的路由,下一跳交给R2的s1/2接口?现在再来用R3 ping R2的Fa0/0接口:R3#ping 192.168.2.2Type escape sequence to abort.1Jo68学习网-学习教育资源分享平台
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:1Jo68学习网-学习教育资源分享平台
!!!!!1Jo68学习网-学习教育资源分享平台
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/163/312 ms?R1#show ip nat translations 1Jo68学习网-学习教育资源分享平台
Pro Inside global????? Inside local?????? Outside local????? Outside global1Jo68学习网-学习教育资源分享平台
icmp 202.96.134.1:6??? 192.168.0.3:6????? 192.168.2.2:6????? 192.168.2.2:6?OK,实验到此圆满完成!我们今天的实验主要演示了基于接口动态获取外部全局IP实现NAT转换和基于地址池获取外部全局IP实现NAT转换。因为我们演示的只有一个外部全局ip地址,所以在创建地址池的时候,开始IP地址和结束IP地址都写的是202.96.134.1,如果是现实中有多个外部全局IP地址,那就要分别指定开始IP地址和结束IP地址了。版权声明:原创作品,如需转载,请与作者联系。否则将追究法律责任

本站所有资源均来自于68学习网蜘蛛爬取结果,如您发现侵权、违法、存在不和谐内容,告知本站一律删除

本站不以盈利为目的,全站资源仅供学习爱好使用。本站站长邮箱:luo689up@foxmail.com

备案号:闽ICP备15018334号-2

©68学习网  2016-2017版权所有     站点地图

回到顶部