网络安全 当前位置:首页 > 计算机学习 > 网络知识 > 网络安全>正文

CCIE试验备考之交换VLAN间路由推荐

【网络安全】 2018-01-26本文已影响
VLAN间路由的方法Vv768学习网-学习教育资源分享平台
方法一Vv768学习网-学习教育资源分享平台
?Vv768学习网-学习教育资源分享平台
路由器的每个接口对应每个vlan,利用路由协议实现vlan之间的路由,这种方法受路由器转发能力的限制,且占用大量的路由器端口Vv768学习网-学习教育资源分享平台
方法二Vv768学习网-学习教育资源分享平台
?利用中继端口(isl或802.1Q)实现多VLAN和路由器子接口的模式,实现单臂路由,这种方法转发带宽受中继链路带宽限制Vv768学习网-学习教育资源分享平台
方法三Vv768学习网-学习教育资源分享平台
?Vv768学习网-学习教育资源分享平台
采用集成了路由处理器的交换机(3层交换机)完成VLAN间路由,这种方法全部采用内部交换链路进行交换,具有速度高,无冲突影响等优点多层交换机实现VLAN间路由Vv768学习网-学习教育资源分享平台
通过使用集成的第3层模块或附属卡,可以实现vlan间路由的选择,同时可以直接访问背板总线,提高了交换速度。路由器被高度集成到交换机中,使得告诉路由选择特性更容易实现。Vv768学习网-学习教育资源分享平台
下图是相应的路由处理器模块Vv768学习网-学习教育资源分享平台
?Vv768学习网-学习教育资源分享平台
为了实现VLAN间的路由,交换机必须使用第3层地址来完成。多层交换机支持多种不同类型的第3层接口:Vv768学习网-学习教育资源分享平台
1.?路由接口Vv768学习网-学习教育资源分享平台
路由端口是一种物理接口,它类似于传统路有器上配置了第3层地址的端口。与接入端口不同的是,路由端口不与特定VLAN相关联。路由端口类似于普通的路由器端口,不同之处在与它不能像路由器那样支持子接口。Vv768学习网-学习教育资源分享平台
路由端口用于点对点链路,路由端口的典型应用就是连接WAN路由器和安全设备。在多层交换机网络中,路由端口大多数都配置于园区主干子模块中的交换机之间。Vv768学习网-学习教育资源分享平台
配置过程:Vv768学习网-学习教育资源分享平台
1)?进入全局模式? configure terminalVv768学习网-学习教育资源分享平台
2)?进入接口模式? interface 接口Vv768学习网-学习教育资源分享平台
3)?配置为路由端口Vv768学习网-学习教育资源分享平台
??????? no switchportVv768学习网-学习教育资源分享平台
案例:Vv768学习网-学习教育资源分享平台
sw(config)#interface g0/1Vv768学习网-学习教育资源分享平台
sw(config-if)#ip address 192.168.0.1 255.255.255.0Vv768学习网-学习教育资源分享平台
% IP addresses may not be configured on L1 LinksVv768学习网-学习教育资源分享平台
出现错误,因为默认情况下,交换机的接口都是接入模式Vv768学习网-学习教育资源分享平台
sw(config-if)#no switchportVv768学习网-学习教育资源分享平台
sw(config-if)#ip address 192.168.0.1 255.255.255.0Vv768学习网-学习教育资源分享平台
sw(config-if)#endVv768学习网-学习教育资源分享平台
案例:Vv768学习网-学习教育资源分享平台
CCIE-LAB(V180)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
SW1和SW2的FA0/3接口与R3相连,IP地址为YY.YY.13.2/30,YY.YY.31.2/30Vv768学习网-学习教育资源分享平台
配置:Vv768学习网-学习教育资源分享平台
SW1 Vv768学习网-学习教育资源分享平台
?? Configure terminalVv768学习网-学习教育资源分享平台
?? Interface f0/3Vv768学习网-学习教育资源分享平台
????? No switchportVv768学习网-学习教育资源分享平台
???? Ip address 11.11.13.2 255.255.255.252Vv768学习网-学习教育资源分享平台
SW2Vv768学习网-学习教育资源分享平台
?? Config termiVv768学习网-学习教育资源分享平台
?? Interface f0/3Vv768学习网-学习教育资源分享平台
????? No switchportVv768学习网-学习教育资源分享平台
????? Ip address 11.11.31.2 255.255.255.252Vv768学习网-学习教育资源分享平台
CCIE-LAB(V210)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
配置SW1的FA0/1,FA0/6,SW2的FA0/2,FA0/4,FA0/5接口的IP地址,用于后面的OSPF路由所用(具体IP地址查看拓扑)Vv768学习网-学习教育资源分享平台
配置:Vv768学习网-学习教育资源分享平台
SW1Vv768学习网-学习教育资源分享平台
?? Config termiVv768学习网-学习教育资源分享平台
?? Interface f0/1Vv768学习网-学习教育资源分享平台
????? No switchportVv768学习网-学习教育资源分享平台
????? Ip address 11.11.17.7 255.255.255.0Vv768学习网-学习教育资源分享平台
?? Interface f0/6Vv768学习网-学习教育资源分享平台
????? No switchportVv768学习网-学习教育资源分享平台
????? Ip address 11.11.67.7 255.255.255.0Vv768学习网-学习教育资源分享平台
SW2Vv768学习网-学习教育资源分享平台
?? config termiVv768学习网-学习教育资源分享平台
?? Interface f0/2Vv768学习网-学习教育资源分享平台
????? No switchportVv768学习网-学习教育资源分享平台
????? Ip address 11.11.28.8 255.255.255.0Vv768学习网-学习教育资源分享平台
?? Interface f0/4Vv768学习网-学习教育资源分享平台
????? No switchportVv768学习网-学习教育资源分享平台
????? Ip address 11.11.48.8 255.255.255.0Vv768学习网-学习教育资源分享平台
2.?交换虚拟接口Vv768学习网-学习教育资源分享平台
交换机虚拟接口(Switch Virtual Interface)是一种第3层接口,它是为在多层交换机上完成VLAN间路由选择而配置的接口。SVI是一种与VLAN ID相关联的虚拟VLAN接口,其目的在于启用该VLAN上的路由选择能力。Vv768学习网-学习教育资源分享平台
配置过程:Vv768学习网-学习教育资源分享平台
1)?进入全局模式? configure terminalVv768学习网-学习教育资源分享平台
2)?进入接口模式? interface vlan vlanIDVv768学习网-学习教育资源分享平台
3)?进行第3层的配置Vv768学习网-学习教育资源分享平台
????????? ip address network-address netmaskVv768学习网-学习教育资源分享平台
4)?启用接口Vv768学习网-学习教育资源分享平台
????????? no shutdownVv768学习网-学习教育资源分享平台
5)?验证结果Vv768学习网-学习教育资源分享平台
????????? show running interface vlan 号Vv768学习网-学习教育资源分享平台
案例:Vv768学习网-学习教育资源分享平台
sw(config)#inteface vlan 10Vv768学习网-学习教育资源分享平台
sw(config-if)#ip address 10.10.1.1 255.0.0.0Vv768学习网-学习教育资源分享平台
sw(config-if)#no shutVv768学习网-学习教育资源分享平台
sw(config-if)#interface vlan 20Vv768学习网-学习教育资源分享平台
sw(config-if)#ip address 10.20.1.1 255.0.0.0Vv768学习网-学习教育资源分享平台
sw(config-if)#no shutVv768学习网-学习教育资源分享平台
sw#show running interface vlan 10Vv768学习网-学习教育资源分享平台
sw#show interface vlan 20Vv768学习网-学习教育资源分享平台
案例:Vv768学习网-学习教育资源分享平台
CCIE-LAB(V135)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
configure SVI interface for vlan 30 and vlan 50,it is for ospf and EIGRP routing later.Vv768学习网-学习教育资源分享平台
配置:Vv768学习网-学习教育资源分享平台
SW1Vv768学习网-学习教育资源分享平台
?? Config termiVv768学习网-学习教育资源分享平台
?? Interface vlan 30Vv768学习网-学习教育资源分享平台
???? Ip address 11.11.57.1 255.255.255.0Vv768学习网-学习教育资源分享平台
???? No shutVv768学习网-学习教育资源分享平台
?? Interface vlan 50Vv768学习网-学习教育资源分享平台
???? Ip address 11.11.37.1 255.255.255.0Vv768学习网-学习教育资源分享平台
???? No shutCCIE-LAB(V142)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
SW1建立VLANA(vlan2)端口,地址142.1.30.7/24,SW1将参与部分路由Vv768学习网-学习教育资源分享平台
SW2建立VLANB(vlan3)端口,地址142.1.8.8/24,SW2不参与路由,但要求在做完IGP路由后所有路由器都能访问Sw1和Sw2的命令行模式。Vv768学习网-学习教育资源分享平台
配置:Vv768学习网-学习教育资源分享平台
SW1Vv768学习网-学习教育资源分享平台
?? Config termiVv768学习网-学习教育资源分享平台
?? Interface vlan 2Vv768学习网-学习教育资源分享平台
???? Ip address 142.1.30.7 255.255.255.0Vv768学习网-学习教育资源分享平台
???? No shutVv768学习网-学习教育资源分享平台
? Interface vlan 3Vv768学习网-学习教育资源分享平台
????? Ip address 142.1.8.8 255.255.255.0Vv768学习网-学习教育资源分享平台
???? No shutVv768学习网-学习教育资源分享平台
案例:Vv768学习网-学习教育资源分享平台
CCIE-LAB(v148)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
Using a switch virtual interface,add Ip address yy.yy.62.8/25 to SW2.Make sure you? do have connectivity to other devices on that network segment.Vv768学习网-学习教育资源分享平台
配置要求:Vv768学习网-学习教育资源分享平台
SW2Vv768学习网-学习教育资源分享平台
Config terminVv768学习网-学习教育资源分享平台
Interface vlan 62Vv768学习网-学习教育资源分享平台
?? Ip address 11.11.62.8 255.255.255.128Vv768学习网-学习教育资源分享平台
?? No shutVv768学习网-学习教育资源分享平台
CCIE-LAB(Vyy)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
为vlan D(vlan 14)启用SVI,IP地址为yy.yy.13.7/24Vv768学习网-学习教育资源分享平台
配置:Vv768学习网-学习教育资源分享平台
SW1Vv768学习网-学习教育资源分享平台
?? Config terVv768学习网-学习教育资源分享平台
?? Interface vlan 14Vv768学习网-学习教育资源分享平台
Ip address 11.11.13.7 255.255.255.0Vv768学习网-学习教育资源分享平台
No shutVv768学习网-学习教育资源分享平台
?? 使用交换机虚拟接口实现VLAN间路由选择的配置过程:Vv768学习网-学习教育资源分享平台
1)?进入全局模式? config terminalVv768学习网-学习教育资源分享平台
2)?启用多层交换机的路由功能Vv768学习网-学习教育资源分享平台
??????? ip routingVv768学习网-学习教育资源分享平台
3)?选择路由协议,用于vlan间的路由(可选)Vv768学习网-学习教育资源分享平台
??????? router 路由协议Vv768学习网-学习教育资源分享平台
4)?定义vlan的SVI接口Vv768学习网-学习教育资源分享平台
??????? interface vlan vlanIDVv768学习网-学习教育资源分享平台
5)?配置第3层参数Vv768学习网-学习教育资源分享平台
??????? ip address 每个VLAN的网关地址 掩码Vv768学习网-学习教育资源分享平台
6)?启用接口Vv768学习网-学习教育资源分享平台
???????? no shutVv768学习网-学习教育资源分享平台
7)?验证结果Vv768学习网-学习教育资源分享平台
案例:Vv768学习网-学习教育资源分享平台
sw(config)#ip routingVv768学习网-学习教育资源分享平台
sw(config)#router ripVv768学习网-学习教育资源分享平台
sw(config-router)#network 192.168.10.0Vv768学习网-学习教育资源分享平台
sw(config-rotuer)#network 192.168.20.0Vv768学习网-学习教育资源分享平台
sw(config)#interface vlan 10Vv768学习网-学习教育资源分享平台
sw(config-if)#ip address 192.168.10.1 255.255.255.0Vv768学习网-学习教育资源分享平台
sw(config-if)#no shutVv768学习网-学习教育资源分享平台
sw(config-if)#interface vlan 20Vv768学习网-学习教育资源分享平台
sw(config-if)#ip address 192.168.20.1 255.255.255.0Vv768学习网-学习教育资源分享平台
sw(config-if)#no shut3.第3层Etherchannel接口单臂路由Vv768学习网-学习教育资源分享平台
采用单臂路由器的最大优点是节约了交换机和路由器的接口,但可能带来路由器产生过载,? 每个Vv768学习网-学习教育资源分享平台
vlan带宽不足或者IOS版本过低,导致仅支持ISL封装,不支持dot1q 等情况发生。Vv768学习网-学习教育资源分享平台
单臂路由的配置方法需要路由器支持Trunk 封装类型,同时还需要路由器支持子接口,并在子接口Vv768学习网-学习教育资源分享平台
上配置各种3 层路由特性。该接口必须是快速以太口或吉比特接口(>100M)Vv768学习网-学习教育资源分享平台
?Vv768学习网-学习教育资源分享平台
配置过程:Vv768学习网-学习教育资源分享平台
路由器部分:Vv768学习网-学习教育资源分享平台
1)?进入全局模式? configure terminalVv768学习网-学习教育资源分享平台
2)?进入接口模式? interface 接口? (该接口是与交换机相连的trunk干道)Vv768学习网-学习教育资源分享平台
3)?主接口中不能配置ip地址Vv768学习网-学习教育资源分享平台
no ip addressVv768学习网-学习教育资源分享平台
4)?根据vlan的数量建立子接口Vv768学习网-学习教育资源分享平台
interface 接口.子接口Vv768学习网-学习教育资源分享平台
5)?设置第3层的参数Vv768学习网-学习教育资源分享平台
ip address 对应vlan的网关地址 子网掩码Vv768学习网-学习教育资源分享平台
6)?配置链路聚集(trunking)封装和对应的vlanVv768学习网-学习教育资源分享平台
encapsulation [dot1q|isl] vlanIDVv768学习网-学习教育资源分享平台
交换机部分:Vv768学习网-学习教育资源分享平台
1)?进入全局模式? configure terminalVv768学习网-学习教育资源分享平台
2)?进入接口模式? interface 接口? (与路由器相连的干道接口)Vv768学习网-学习教育资源分享平台
3)?配置该接口trunk的封装类型Vv768学习网-学习教育资源分享平台
switchport trunk encapsulation [dot1q|isl]Vv768学习网-学习教育资源分享平台
switchport mode trunkVv768学习网-学习教育资源分享平台
案例:Vv768学习网-学习教育资源分享平台
R1(config)#interface f0/1Vv768学习网-学习教育资源分享平台
R1(config-if)#no ip addressVv768学习网-学习教育资源分享平台
R1(config-if)#no shutVv768学习网-学习教育资源分享平台
R1(config-if)#interface f0/1.1Vv768学习网-学习教育资源分享平台
R1(config-if)#encapsulation dot1q 10Vv768学习网-学习教育资源分享平台
R1(config-if)#ip address 192.168.1.1 255.255.255.0Vv768学习网-学习教育资源分享平台
R1(config-if)#interface f0/1.2Vv768学习网-学习教育资源分享平台
R1(config-if)#encapsulation dot1q 20Vv768学习网-学习教育资源分享平台
R1(config-if)#ip address 192.168.2.1 255.255.255.0Vv768学习网-学习教育资源分享平台
R1(config-if)#interface f0/1.3Vv768学习网-学习教育资源分享平台
R1(config-if)#encapsulation dot1q 30Vv768学习网-学习教育资源分享平台
R1(config-if)#ip address 192.168.3.1 255.255.255.0Vv768学习网-学习教育资源分享平台
Sw(config)#interface f0/1Vv768学习网-学习教育资源分享平台
Sw(config-if)#switchport trunk encapsulation dot1qVv768学习网-学习教育资源分享平台
Sw(config-if)#switchport mode trunkVv768学习网-学习教育资源分享平台
案例:Vv768学习网-学习教育资源分享平台
CCIE-LAB(V133)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
R1与R2的一个快速以太口,被划到2个VLAN中,大家要采用在路由器子接口上封装相应的VLAN,并且TRUNK模式为DOT1Q。相对应交换机的端口为TURNK,模式为dot1Q,允许相应VLAN通过。Vv768学习网-学习教育资源分享平台
?Vv768学习网-学习教育资源分享平台
vlan 10 name vlan bb1Vv768学习网-学习教育资源分享平台
vlan 20 name vlan DVv768学习网-学习教育资源分享平台
vlan? 2 name vlan AVv768学习网-学习教育资源分享平台
配置:Vv768学习网-学习教育资源分享平台
R1Vv768学习网-学习教育资源分享平台
?? Config termVv768学习网-学习教育资源分享平台
?? Interface f0/0Vv768学习网-学习教育资源分享平台
???? No ip addressVv768学习网-学习教育资源分享平台
?? Interface f0/0.1Vv768学习网-学习教育资源分享平台
???? Encapsulation dot1q 10Vv768学习网-学习教育资源分享平台
???? Ip address 150.100.1.1 255.255.255.0Vv768学习网-学习教育资源分享平台
?? Interface f0/0.2Vv768学习网-学习教育资源分享平台
????? Encapsulation dot1q 20Vv768学习网-学习教育资源分享平台
????? Ip address 11.11.12.1 255.255.255.0Vv768学习网-学习教育资源分享平台
R2Vv768学习网-学习教育资源分享平台
?? Config termVv768学习网-学习教育资源分享平台
?? Interface f0/0Vv768学习网-学习教育资源分享平台
???? No ip addressVv768学习网-学习教育资源分享平台
?? Interface f0/0.1Vv768学习网-学习教育资源分享平台
???? Encapsulation dot1q 20Vv768学习网-学习教育资源分享平台
???? Ip address 11.11.12.2 255.255.255.0Vv768学习网-学习教育资源分享平台
?? Interface f0/0.2Vv768学习网-学习教育资源分享平台
???? Encapsulation dot1q 2Vv768学习网-学习教育资源分享平台
???? Ip address 11.11.23.1 255.255.255.0Vv768学习网-学习教育资源分享平台
Sw1Vv768学习网-学习教育资源分享平台
Config terminalVv768学习网-学习教育资源分享平台
Interface f0/1Vv768学习网-学习教育资源分享平台
?? Switchport trunk encapsulation dot1qVv768学习网-学习教育资源分享平台
?? Switchport mode trunkVv768学习网-学习教育资源分享平台
?? Switchport trunk allowed vlan noneVv768学习网-学习教育资源分享平台
?? Switchport trunk allowed vlan 10,20Vv768学习网-学习教育资源分享平台
Interface f0/2Vv768学习网-学习教育资源分享平台
?? Switchport trunk encap dot1qVv768学习网-学习教育资源分享平台
?? Switchport mode trunkVv768学习网-学习教育资源分享平台
?? Switchport trunk allowed vlan noneVv768学习网-学习教育资源分享平台
?? Switchport trunk allowed vlan 2,20CCIE-LAB(V135)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
?Vv768学习网-学习教育资源分享平台
R6的FA0/1起子接口,封装模式为DOT1Q,做单臂路由,只允许相应的vlanVv768学习网-学习教育资源分享平台
配置:Vv768学习网-学习教育资源分享平台
R6Vv768学习网-学习教育资源分享平台
Config terminalVv768学习网-学习教育资源分享平台
Interface f0/1Vv768学习网-学习教育资源分享平台
?? No ip addressVv768学习网-学习教育资源分享平台
?? No shutVv768学习网-学习教育资源分享平台
?? Interface f0/1.1Vv768学习网-学习教育资源分享平台
????? Encapsulation dot1q 13Vv768学习网-学习教育资源分享平台
????? Ip address 11.11.68.6 255.255.255.0Vv768学习网-学习教育资源分享平台
?? Interface f0/1.2Vv768学习网-学习教育资源分享平台
????? Encapsulation dot1q 60Vv768学习网-学习教育资源分享平台
????? Ip address 192.2.1.11 255.255.255.0Vv768学习网-学习教育资源分享平台
SW2Vv768学习网-学习教育资源分享平台
Config terminalVv768学习网-学习教育资源分享平台
Interface f0/6Vv768学习网-学习教育资源分享平台
?? Switchport trunk encapsulation dot1qVv768学习网-学习教育资源分享平台
?? Switchport mode trunkVv768学习网-学习教育资源分享平台
?? Switchport trunk allowed vlan noneVv768学习网-学习教育资源分享平台
?? Switchport trunk allowed vlan 13,60CCIE-LAB(YY)Vv768学习网-学习教育资源分享平台
题目要求:Vv768学习网-学习教育资源分享平台
?Vv768学习网-学习教育资源分享平台
R6的fa0/0使用单臂路由,包括两个接口,fa0/0.1连接bb1,fa0/0.XX连接bb3,要限制该有的vlan。Vv768学习网-学习教育资源分享平台
配置:Vv768学习网-学习教育资源分享平台
SW1Vv768学习网-学习教育资源分享平台
config terminalVv768学习网-学习教育资源分享平台
interface f0/6Vv768学习网-学习教育资源分享平台
?? switchport trunk encapsulation dot1qVv768学习网-学习教育资源分享平台
?? switchport mode trunkVv768学习网-学习教育资源分享平台
?? switchport trunk allowed vlan 15,17Vv768学习网-学习教育资源分享平台
R6Vv768学习网-学习教育资源分享平台
config terminalVv768学习网-学习教育资源分享平台
interface f0/0Vv768学习网-学习教育资源分享平台
?? no ip addressVv768学习网-学习教育资源分享平台
?? no shutVv768学习网-学习教育资源分享平台
?? inteface f0/0.1Vv768学习网-学习教育资源分享平台
????? encapsulation dot1q 15Vv768学习网-学习教育资源分享平台
????? ip address 150.1.1.11 255.255.255.0Vv768学习网-学习教育资源分享平台
?? interface f0/0.2Vv768学习网-学习教育资源分享平台
????? encapsulation dot1q 17Vv768学习网-学习教育资源分享平台
????? ip address 192.168.2.11 255.255.255.0??版权声明:原创作品,如需转载,请与作者联系。否则将追究法律责任

本站所有资源均来自于68学习网蜘蛛爬取结果,如您发现侵权、违法、存在不和谐内容,告知本站一律删除

本站不以盈利为目的,全站资源仅供学习爱好使用。本站站长邮箱:luo689up@foxmail.com

备案号:闽ICP备15018334号-2

©68学习网  2016-2017版权所有     站点地图

回到顶部