网络安全 当前位置:首页 > 计算机学习 > 网络知识 > 网络安全>正文

流量策略和整型--整型篇推荐

【网络安全】 2018-01-26本文已影响
拓扑描述l0368学习网-学习教育资源分享平台
R1: f1/0? 10.1.1.1/24l0368学习网-学习教育资源分享平台
R2: f0/0? 10.1.2.2/24l0368学习网-学习教育资源分享平台
R3: f0/0 10.1.2.3/24? f1/0 10.1.1.3/24 s2/0 10.1.3.3/24l0368学习网-学习教育资源分享平台
R4: s2/0 10.1.3.4/24l0368学习网-学习教育资源分享平台
全网启用RIPv2
?初始配置l0368学习网-学习教育资源分享平台
R1l0368学习网-学习教育资源分享平台
conf tl0368学习网-学习教育资源分享平台
int f1/0l0368学习网-学习教育资源分享平台
ip ad 10.1.1.1 255.255.255.0l0368学习网-学习教育资源分享平台
no shutl0368学习网-学习教育资源分享平台
router ripl0368学习网-学习教育资源分享平台
ver 2l0368学习网-学习教育资源分享平台
no aul0368学习网-学习教育资源分享平台
net 10.0.0.0l0368学习网-学习教育资源分享平台
line vty 0 4l0368学习网-学习教育资源分享平台
password ciscol0368学习网-学习教育资源分享平台
loginl0368学习网-学习教育资源分享平台
end
?R2l0368学习网-学习教育资源分享平台
conf tl0368学习网-学习教育资源分享平台
int f 0/0l0368学习网-学习教育资源分享平台
ip ad? 10.1.2.2 255.255.255.0l0368学习网-学习教育资源分享平台
no shutl0368学习网-学习教育资源分享平台
router ripl0368学习网-学习教育资源分享平台
ver 2l0368学习网-学习教育资源分享平台
no aul0368学习网-学习教育资源分享平台
net 10.0.0.0l0368学习网-学习教育资源分享平台
end
?R3l0368学习网-学习教育资源分享平台
conf tl0368学习网-学习教育资源分享平台
int f 0/0l0368学习网-学习教育资源分享平台
ip ad 10.1.2.3 255.255.255.0l0368学习网-学习教育资源分享平台
no shutl0368学习网-学习教育资源分享平台
int f1/0l0368学习网-学习教育资源分享平台
ip ad 10.1.1.3 255.255.255.0l0368学习网-学习教育资源分享平台
no shutl0368学习网-学习教育资源分享平台
int s2/0l0368学习网-学习教育资源分享平台
ip ad 10.1.3.3 255.255.255.0l0368学习网-学习教育资源分享平台
encap fl0368学习网-学习教育资源分享平台
no arp fl0368学习网-学习教育资源分享平台
no frame inverl0368学习网-学习教育资源分享平台
frame map ip 10.1.3.4 304 bl0368学习网-学习教育资源分享平台
no shutl0368学习网-学习教育资源分享平台
router ripl0368学习网-学习教育资源分享平台
ver 2l0368学习网-学习教育资源分享平台
no aul0368学习网-学习教育资源分享平台
net 10.0.0.0l0368学习网-学习教育资源分享平台
end
?R4l0368学习网-学习教育资源分享平台
conf tl0368学习网-学习教育资源分享平台
int s2/0l0368学习网-学习教育资源分享平台
ip ad 10.1.3.4 255.255.255.0l0368学习网-学习教育资源分享平台
encap fl0368学习网-学习教育资源分享平台
no arp fl0368学习网-学习教育资源分享平台
no frame inverl0368学习网-学习教育资源分享平台
frame map ip 10.1.3.3 403 bl0368学习网-学习教育资源分享平台
no shutl0368学习网-学习教育资源分享平台
router rip l0368学习网-学习教育资源分享平台
ver 2l0368学习网-学习教育资源分享平台
no au l0368学习网-学习教育资源分享平台
net 10.0.0.0l0368学习网-学习教育资源分享平台
line vty 0 4l0368学习网-学习教育资源分享平台
password ciscol0368学习网-学习教育资源分享平台
loginl0368学习网-学习教育资源分享平台
end
??1,使用Generic Traffic Shaping(GTS)对流量整型l0368学习网-学习教育资源分享平台
在R3的F1/0上对R4去往R1的telnet流量整型,限速1MBPSl0368学习网-学习教育资源分享平台
在R3的F0/0上对R4去往R2的所有流量整型,限速5MBPSl0368学习网-学习教育资源分享平台
在R3的S2/0上对R1去往R4的UDP流量整型, 发送速率500KBPS,最低速率300KBPS
l0368学习网-学习教育资源分享平台
R3l0368学习网-学习教育资源分享平台
conf tl0368学习网-学习教育资源分享平台
access-list 100 permit tcp host 10.1.3.4 host 10.1.1.1 eq telnetl0368学习网-学习教育资源分享平台
int f1/0l0368学习网-学习教育资源分享平台
traffic-shape group 100 1000000l0368学习网-学习教育资源分享平台
int f0/0l0368学习网-学习教育资源分享平台
traffic-shape rate 5000000l0368学习网-学习教育资源分享平台
int s2/0l0368学习网-学习教育资源分享平台
traffic-shape rate 500000traffic-shape adaptive 300000traffic-shape fecn-adaptl0368学习网-学习教育资源分享平台
end
?校验l0368学习网-学习教育资源分享平台
先在R4上PING R2l0368学习网-学习教育资源分享平台
R4#ping 10.1.2.2
Type escape sequence to abort.l0368学习网-学习教育资源分享平台
Sending 5, 100-byte ICMP Echos to 10.1.2.2, timeout is 2 seconds:l0368学习网-学习教育资源分享平台
!!!!!l0368学习网-学习教育资源分享平台
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/92/248 ms
在R4上TELNET R1l0368学习网-学习教育资源分享平台
R4#telnet 10.1.1.1l0368学习网-学习教育资源分享平台
Trying 10.1.1.1 ... Open
l0368学习网-学习教育资源分享平台
User Access VerificationPassword: R1>quit[Connection to 10.1.1.1 closed by foreign host]l0368学习网-学习教育资源分享平台
在R1上trace R4l0368学习网-学习教育资源分享平台
R1#trace 10.1.3.4
Type escape sequence to abort.l0368学习网-学习教育资源分享平台
Tracing the route to 10.1.3.4
? 1 10.1.1.3 84 msec 32 msec 72 msecl0368学习网-学习教育资源分享平台
? 2 10.1.3.4 56 msec *? 100 msec
l0368学习网-学习教育资源分享平台
在R3上看结果l0368学习网-学习教育资源分享平台
R3#sh traffic-shape statistics f1/0l0368学习网-学习教育资源分享平台
????????????????? Acc. Queue Packets?? Bytes???? Packets?? Bytes???? Shapingl0368学习网-学习教育资源分享平台
I/F?????????????? List Depth???????????????????? Delayed?? Delayed?? Activel0368学习网-学习教育资源分享平台
Fa1/0?????????????? 100 0???? 30??????? 1667????? 0???????? 0???????? nol0368学习网-学习教育资源分享平台
R3#sh traffic-shape statistics f0/0l0368学习网-学习教育资源分享平台
????????????????? Acc. Queue Packets?? Bytes???? Packets?? Bytes???? Shapingl0368学习网-学习教育资源分享平台
I/F?????????????? List Depth???????????????????? Delayed?? Delayed?? Activel0368学习网-学习教育资源分享平台
Fa0/0?????????????????? 0???? 17??????? 1673????? 0???????? 0???????? nol0368学习网-学习教育资源分享平台
R3#sh traffic-shape f1/0??????????
Interface?? Fa1/0l0368学习网-学习教育资源分享平台
?????? Access Target??? Byte?? Sustain?? Excess??? Interval? Increment Adaptl0368学习网-学习教育资源分享平台
VC???? List?? Rate????? Limit? bits/int? bits/int? (ms)????? (bytes)?? Activel0368学习网-学习教育资源分享平台
-????? 100??? 1000000?? 6250?? 25000???? 25000???? 25??????? 3125????? -?? l0368学习网-学习教育资源分享平台
R3#sh traffic-shape f0/0??????????
Interface?? Fa0/0l0368学习网-学习教育资源分享平台
?????? Access Target??? Byte?? Sustain?? Excess??? Interval? Increment Adaptl0368学习网-学习教育资源分享平台
VC???? List?? Rate????? Limit? bits/int? bits/int? (ms)????? (bytes)?? Activel0368学习网-学习教育资源分享平台
-???????????? 5000000?? 31250? 125000??? 125000??? 25??????? 15625???? -??
R3#sh traffic-shape statistics s2/0l0368学习网-学习教育资源分享平台
????????????????? Acc. Queue Packets?? Bytes???? Packets?? Bytes???? Shapingl0368学习网-学习教育资源分享平台
I/F?????????????? List Depth???????????????????? Delayed?? Delayed?? Activel0368学习网-学习教育资源分享平台
Se2/0?????????????? 101 0???? 3???????? 96??????? 0???????? 0???????? nol0368学习网-学习教育资源分享平台
R3#sh traffic-shape s2/0??????????
Interface?? Se2/0l0368学习网-学习教育资源分享平台
?????? Access Target??? Byte?? Sustain?? Excess??? Interval? Increment Adaptl0368学习网-学习教育资源分享平台
VC???? List?? Rate????? Limit? bits/int? bits/int? (ms)????? (bytes)?? Activel0368学习网-学习教育资源分享平台
-????? 101??? 500000??? 3000?? 12000???? 12000???? 24??????? 1500????? BECN
??2, Class-based Shapingl0368学习网-学习教育资源分享平台
在R3上定义两个类CBS1和CBS2,使得R1去往R4的telnet流量的带宽512K,在出口时整型为平均速率为600KR2去往R4的流量时整型,使得其peak值为256K
l0368学习网-学习教育资源分享平台
R3l0368学习网-学习教育资源分享平台
conf tl0368学习网-学习教育资源分享平台
access-list 100 permit tcp host 10.1.1.1 host 10.1.3.4 eq telnetl0368学习网-学习教育资源分享平台
access-list 101 permit ip host 10.1.2.2 host 10.1.3.4l0368学习网-学习教育资源分享平台
class-map CBS1l0368学习网-学习教育资源分享平台
match access-group 100l0368学习网-学习教育资源分享平台
class-map CBS2l0368学习网-学习教育资源分享平台
match access-group 101l0368学习网-学习教育资源分享平台
policy-map TOR4l0368学习网-学习教育资源分享平台
class CBS1l0368学习网-学习教育资源分享平台
shape average 600000l0368学习网-学习教育资源分享平台
bandwidth 512
l0368学习网-学习教育资源分享平台
class CBS2l0368学习网-学习教育资源分享平台
shape peak 256000l0368学习网-学习教育资源分享平台
int s2/0l0368学习网-学习教育资源分享平台
service-policy output TOR4l0368学习网-学习教育资源分享平台
end
?校验l0368学习网-学习教育资源分享平台
在R1上TELNET R4l0368学习网-学习教育资源分享平台
R1#trace 10.1.3.4
Type escape sequence to abort.l0368学习网-学习教育资源分享平台
Tracing the route to 10.1.3.4
? 1 10.1.1.3 84 msec 32 msec 72 msecl0368学习网-学习教育资源分享平台
? 2 10.1.3.4 56 msec *? 100 msecl0368学习网-学习教育资源分享平台
R1#telnet 10.1.3.4l0368学习网-学习教育资源分享平台
Trying 10.1.3.4 ... Open
l0368学习网-学习教育资源分享平台
User Access VerificationPassword: l0368学习网-学习教育资源分享平台
R4>quit
[Connection to 10.1.3.4 closed by foreign host]l0368学习网-学习教育资源分享平台
R1#
?在R2上PING R4l0368学习网-学习教育资源分享平台
R2#ping 10.1.3.4
Type escape sequence to abort.l0368学习网-学习教育资源分享平台
Sending 5, 100-byte ICMP Echos to 10.1.3.4, timeout is 2 seconds:l0368学习网-学习教育资源分享平台
!!!!!l0368学习网-学习教育资源分享平台
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/66/148 ms
l0368学习网-学习教育资源分享平台
在R3上检查结果l0368学习网-学习教育资源分享平台
R3#SH policy-map int s2/0
?Serial2/0 ? Service-policy output: TOR4??? Class-map: CBS1 (match-all)l0368学习网-学习教育资源分享平台
????? 23 packets, 1053 bytesl0368学习网-学习教育资源分享平台
????? 5 minute offered rate 0 bps, drop rate 0 bpsl0368学习网-学习教育资源分享平台
????? Match: access-group 100l0368学习网-学习教育资源分享平台
????? Traffic Shapingl0368学习网-学习教育资源分享平台
?????????? Target/Average?? Byte?? Sustain?? Excess??? Interval? Incrementl0368学习网-学习教育资源分享平台
???????????? Rate?????????? Limit? bits/int? bits/int? (ms)????? (bytes)? l0368学习网-学习教育资源分享平台
?????????? 600000/600000??? 3750?? 15000???? 15000???? 25??????? 1875????
??????? Adapt? Queue???? Packets?? Bytes???? Packets?? Bytes???? Shapingl0368学习网-学习教育资源分享平台
??????? Active Depth???????????????????????? Delayed?? Delayed?? Activel0368学习网-学习教育资源分享平台
??????? -????? 0???????? 23??????? 1053????? 0???????? 0???????? nol0368学习网-学习教育资源分享平台
????? Queueingl0368学习网-学习教育资源分享平台
??????? Output Queue: Conversation 265 l0368学习网-学习教育资源分享平台
??????? Bandwidth 512 (kbps) Max Threshold 64 (packets)l0368学习网-学习教育资源分享平台
??????? (pkts matched/bytes matched) 1/53l0368学习网-学习教育资源分享平台
??????? (depth/total drops/no-buffer drops) 0/0/0
??? Class-map: CBS2 (match-all)l0368学习网-学习教育资源分享平台
????? 20 packets, 2080 bytesl0368学习网-学习教育资源分享平台
????? 5 minute offered rate 0 bps, drop rate 0 bpsl0368学习网-学习教育资源分享平台
????? Match: access-group 101l0368学习网-学习教育资源分享平台
????? Traffic Shapingl0368学习网-学习教育资源分享平台
?????????? Target/Average?? Byte?? Sustain?? Excess??? Interval? Incrementl0368学习网-学习教育资源分享平台
???????????? Rate?????????? Limit? bits/int? bits/int? (ms)????? (bytes)? l0368学习网-学习教育资源分享平台
?????????? 512000/256000??? 1984?? 7936????? 7936????? 31??????? 1984????
??????? Adapt? Queue???? Packets?? Bytes???? Packets?? Bytes???? Shapingl0368学习网-学习教育资源分享平台
??????? Active Depth???????????????????????? Delayed?? Delayed?? Activel0368学习网-学习教育资源分享平台
??????? -????? 0???????? 20??????? 2080????? 0???????? 0???????? no
??? Class-map: class-default (match-any)l0368学习网-学习教育资源分享平台
????? 14 packets, 524 bytesl0368学习网-学习教育资源分享平台
????? 5 minute offered rate 0 bps, drop rate 0 bpsl0368学习网-学习教育资源分享平台
????? Match: any
版权声明:原创作品,谢绝转载。否则将追究法律责任

本站所有资源均来自于68学习网蜘蛛爬取结果,如您发现侵权、违法、存在不和谐内容,告知本站一律删除

本站不以盈利为目的,全站资源仅供学习爱好使用。本站站长邮箱:luo689up@foxmail.com

备案号:闽ICP备15018334号-2

©68学习网  2016-2017版权所有     站点地图

回到顶部