网络安全 当前位置:首页 > 计算机学习 > 网络知识 > 网络安全>正文

实验指南:BGP路由过滤推荐

【网络安全】 2018-01-26本文已影响
实验指南??BGP路由过滤初始配置TS668学习网-学习教育资源分享平台
R1TS668学习网-学习教育资源分享平台
conf tTS668学习网-学习教育资源分享平台
int l 0TS668学习网-学习教育资源分享平台
ip ad 1.1.1.1 255.255.255.255TS668学习网-学习教育资源分享平台
int s2/0TS668学习网-学习教育资源分享平台
ip ad 10.1.1.1 255.255.255.0TS668学习网-学习教育资源分享平台
encap fTS668学习网-学习教育资源分享平台
no arp fTS668学习网-学习教育资源分享平台
no frame inverTS668学习网-学习教育资源分享平台
frame map ip 10.1.1.2 102 bTS668学习网-学习教育资源分享平台
no shutTS668学习网-学习教育资源分享平台
int s 2/1TS668学习网-学习教育资源分享平台
encap fTS668学习网-学习教育资源分享平台
no arp fTS668学习网-学习教育资源分享平台
no frame inverTS668学习网-学习教育资源分享平台
frame map ip 10.1.4.4 114 bTS668学习网-学习教育资源分享平台
ip ad 10.1.4.1 255.255.255.0TS668学习网-学习教育资源分享平台
no shutTS668学习网-学习教育资源分享平台
exitTS668学习网-学习教育资源分享平台
router ripTS668学习网-学习教育资源分享平台
ver 2TS668学习网-学习教育资源分享平台
no auTS668学习网-学习教育资源分享平台
net 10.0.0.0TS668学习网-学习教育资源分享平台
net 1.0.0.0TS668学习网-学习教育资源分享平台
router bgp 1TS668学习网-学习教育资源分享平台
bgp router-id 1.1.1.1TS668学习网-学习教育资源分享平台
no auTS668学习网-学习教育资源分享平台
no syTS668学习网-学习教育资源分享平台
nei 4.4.4.4 remote-as 654TS668学习网-学习教育资源分享平台
nei 4.4.4.4 up l 0TS668学习网-学习教育资源分享平台
nei 4.4.4.4 ebgp 255TS668学习网-学习教育资源分享平台
nei 2.2.2.2 remote-as 11151TS668学习网-学习教育资源分享平台
nei 2.2.2.2 up l 0TS668学习网-学习教育资源分享平台
nei 2.2.2.2 ebgp 255TS668学习网-学习教育资源分享平台
end
TS668学习网-学习教育资源分享平台
R2TS668学习网-学习教育资源分享平台
conf tTS668学习网-学习教育资源分享平台
int l 0TS668学习网-学习教育资源分享平台
ip ad 2.2.2.2 255.255.255.255TS668学习网-学习教育资源分享平台
interface Loopback1TS668学习网-学习教育资源分享平台
?ip address 20.1.1.1 255.255.255.0TS668学习网-学习教育资源分享平台
interface Loopback2TS668学习网-学习教育资源分享平台
?ip address 20.1.2.1 255.255.255.0TS668学习网-学习教育资源分享平台
interface Loopback3TS668学习网-学习教育资源分享平台
?ip address 20.1.3.1 255.255.255.0TS668学习网-学习教育资源分享平台
interface Loopback4TS668学习网-学习教育资源分享平台
?ip address 20.1.4.1 255.255.255.0TS668学习网-学习教育资源分享平台
interface Loopback5TS668学习网-学习教育资源分享平台
?ip address 20.1.5.1 255.255.255.0TS668学习网-学习教育资源分享平台
int s2/0TS668学习网-学习教育资源分享平台
ip ad 10.1.1.2 255.255.255.0TS668学习网-学习教育资源分享平台
encap fTS668学习网-学习教育资源分享平台
no arp fTS668学习网-学习教育资源分享平台
no frame inverTS668学习网-学习教育资源分享平台
frame map ip 10.1.1.1 201 bTS668学习网-学习教育资源分享平台
no shutTS668学习网-学习教育资源分享平台
int? s2/1TS668学习网-学习教育资源分享平台
ip ad 10.1.2.2 255.255.255.0TS668学习网-学习教育资源分享平台
encap fTS668学习网-学习教育资源分享平台
no arp fTS668学习网-学习教育资源分享平台
no frame inverTS668学习网-学习教育资源分享平台
frame map ip 10.1.2.3 213 b TS668学习网-学习教育资源分享平台
no shutTS668学习网-学习教育资源分享平台
router ripTS668学习网-学习教育资源分享平台
ver 2TS668学习网-学习教育资源分享平台
no auTS668学习网-学习教育资源分享平台
net 10.0.0.0TS668学习网-学习教育资源分享平台
net 2.0.0.0TS668学习网-学习教育资源分享平台
router bgp 11151TS668学习网-学习教育资源分享平台
no auTS668学习网-学习教育资源分享平台
no syTS668学习网-学习教育资源分享平台
bgp router-id 2.2.2.2TS668学习网-学习教育资源分享平台
nei 1.1.1.1 remote-as 1TS668学习网-学习教育资源分享平台
nei 1.1.1.1 up l 0TS668学习网-学习教育资源分享平台
nei 1.1.1.1 ebgp 255TS668学习网-学习教育资源分享平台
nei 3.3.3.3 remote-as 65001TS668学习网-学习教育资源分享平台
nei 3.3.3.3 up l 0TS668学习网-学习教育资源分享平台
nei 3.3.3.3 ebgp 255TS668学习网-学习教育资源分享平台
end
?R3TS668学习网-学习教育资源分享平台
conf tTS668学习网-学习教育资源分享平台
int l 0TS668学习网-学习教育资源分享平台
ip ad 3.3.3.3 255.255.255.255TS668学习网-学习教育资源分享平台
int l 1 TS668学习网-学习教育资源分享平台
ip ad 23.75.18.1 255.255.255.0TS668学习网-学习教育资源分享平台
int l 2TS668学习网-学习教育资源分享平台
ip ad? 23.75.19.1 255.255.255.0TS668学习网-学习教育资源分享平台
int l 3TS668学习网-学习教育资源分享平台
ip ad? 23.75.20.1 255.255.255.0TS668学习网-学习教育资源分享平台
int l 4TS668学习网-学习教育资源分享平台
ip ad? 23.75.21.1 255.255.255.0TS668学习网-学习教育资源分享平台
int l 5TS668学习网-学习教育资源分享平台
ip ad? 23.75.22.1 255.255.255.0TS668学习网-学习教育资源分享平台
int l 6TS668学习网-学习教育资源分享平台
ip ad? 23.75.23.1 255.255.255.0TS668学习网-学习教育资源分享平台
int l 7TS668学习网-学习教育资源分享平台
ip ad? 23.75.24.1 255.255.255.0TS668学习网-学习教育资源分享平台
int l 8TS668学习网-学习教育资源分享平台
ip ad? 23.75.25.1 255.255.255.0TS668学习网-学习教育资源分享平台
int l 9TS668学习网-学习教育资源分享平台
ip ad? 23.75.26.1 255.255.255.0TS668学习网-学习教育资源分享平台
int s 2/1TS668学习网-学习教育资源分享平台
ip ad 10.1.2.3 255.255.255.0TS668学习网-学习教育资源分享平台
encap fTS668学习网-学习教育资源分享平台
no arp fTS668学习网-学习教育资源分享平台
no frame inverTS668学习网-学习教育资源分享平台
frame map ip 10.1.2.2 312 bTS668学习网-学习教育资源分享平台
no shutTS668学习网-学习教育资源分享平台
router ripTS668学习网-学习教育资源分享平台
ver 2TS668学习网-学习教育资源分享平台
no auTS668学习网-学习教育资源分享平台
net 10.0.0.0TS668学习网-学习教育资源分享平台
net 3.0.0.0TS668学习网-学习教育资源分享平台
router bgp 65001TS668学习网-学习教育资源分享平台
no auTS668学习网-学习教育资源分享平台
no syTS668学习网-学习教育资源分享平台
bgp router-id 3.3.3.3TS668学习网-学习教育资源分享平台
nei 2.2.2.2 remote-as 11151TS668学习网-学习教育资源分享平台
nei 2.2.2.2 up l 0TS668学习网-学习教育资源分享平台
nei 2.2.2.2 e 255TS668学习网-学习教育资源分享平台
net 23.75.18.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
net 23.75.19.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
net 23.75.20.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
net 23.75.21.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
net 23.75.22.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
net 23.75.23.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
net 23.75.24.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
net 23.75.25.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
net 23.75.26.0 mask 255.255.255.0TS668学习网-学习教育资源分享平台
end
TS668学习网-学习教育资源分享平台
R4TS668学习网-学习教育资源分享平台
conf tTS668学习网-学习教育资源分享平台
int l 0TS668学习网-学习教育资源分享平台
ip ad 4.4.4.4 255.255.255.255TS668学习网-学习教育资源分享平台
int l 1TS668学习网-学习教育资源分享平台
ip ad? 189.168.56.1 255.255.254.0TS668学习网-学习教育资源分享平台
int l 2TS668学习网-学习教育资源分享平台
ip ad? 189.168.58.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l3TS668学习网-学习教育资源分享平台
ip ad 189.168.60.1 255.255.254.0TS668学习网-学习教育资源分享平台
int l4TS668学习网-学习教育资源分享平台
ip ad? 189.168.62.1 255.255.254.0TS668学习网-学习教育资源分享平台
int l5TS668学习网-学习教育资源分享平台
?ip ad 189.168.64.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l6TS668学习网-学习教育资源分享平台
ip ad 189.168.66.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l7TS668学习网-学习教育资源分享平台
ip ad 189.168.68.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l8TS668学习网-学习教育资源分享平台
ip ad 189.168.70.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l9TS668学习网-学习教育资源分享平台
ip ad 189.168.72.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l10TS668学习网-学习教育资源分享平台
ip ad 189.168.74.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l11TS668学习网-学习教育资源分享平台
ip ad 189.168.76.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l12TS668学习网-学习教育资源分享平台
ip ad 189.168.78.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l13TS668学习网-学习教育资源分享平台
ip ad 189.168.80.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l14TS668学习网-学习教育资源分享平台
ip ad 189.168.82.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l15TS668学习网-学习教育资源分享平台
ip ad 189.168.84.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l16TS668学习网-学习教育资源分享平台
ip ad 189.168.86.1 255.255.254.0TS668学习网-学习教育资源分享平台
?int l17TS668学习网-学习教育资源分享平台
ip ad 189.168.88.1 255.255.254.0TS668学习网-学习教育资源分享平台
int s 2/1TS668学习网-学习教育资源分享平台
ip ad 10.1.4.4 255.255.255.0TS668学习网-学习教育资源分享平台
encap fTS668学习网-学习教育资源分享平台
no arp fTS668学习网-学习教育资源分享平台
no frame inverTS668学习网-学习教育资源分享平台
frame map ip 10.1.4.1 411 bTS668学习网-学习教育资源分享平台
no shutTS668学习网-学习教育资源分享平台
router ripTS668学习网-学习教育资源分享平台
ver 2TS668学习网-学习教育资源分享平台
no auTS668学习网-学习教育资源分享平台
net 10.0.0.0TS668学习网-学习教育资源分享平台
net 4.0.0.0TS668学习网-学习教育资源分享平台
router bgp 654TS668学习网-学习教育资源分享平台
no auTS668学习网-学习教育资源分享平台
no syTS668学习网-学习教育资源分享平台
bgp router-id 4.4.4.4TS668学习网-学习教育资源分享平台
nei 1.1.1.1 remote 1TS668学习网-学习教育资源分享平台
nei 1.1.1.1 up l 0TS668学习网-学习教育资源分享平台
nei 1.1.1.1 e 255TS668学习网-学习教育资源分享平台
net 189.168.56.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.58.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.60.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.62.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.64.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.66.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.68.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.70.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.72.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.74.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.76.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.78.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.80.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.82.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.84.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.86.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
net 189.168.88.0 mask 255.255.254.0TS668学习网-学习教育资源分享平台
end
TS668学习网-学习教育资源分享平台
1,过滤私有ASTS668学习网-学习教育资源分享平台
在R1上BGP表的状态TS668学习网-学习教育资源分享平台
R1(config-router)#do sh ip bgpTS668学习网-学习教育资源分享平台
BGP table version is 145, local router ID is 1.1.1.1TS668学习网-学习教育资源分享平台
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,TS668学习网-学习教育资源分享平台
????????????? r RIB-failure, S StaleTS668学习网-学习教育资源分享平台
Origin codes: i - IGP, e - EGP, ? - incomplete
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 20.1.1.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.2.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.3.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.4.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.5.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.18.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.19.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.20.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.21.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.22.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.23.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.24.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.25.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.26.0/24??? 2.2.2.2??????????????????????????????? 0 11151 65001 i
TS668学习网-学习教育资源分享平台
*> 189.168.56.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.58.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.60.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 189.168.62.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.64.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.66.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.68.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.70.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.72.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.74.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.76.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.78.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.80.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.82.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.84.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.86.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.88.0/23? 4.4.4.4????????????????? 0???????????? 0 654 i
?因为65001是私有AS(范围64512~65535),有时并不希望把私有AS发布到对端,所以在R2上配置TS668学习网-学习教育资源分享平台
router bgp 11151
nei 1.1.1.1 remove-private-ASTS668学习网-学习教育资源分享平台
R2#clear ip bgp * sTS668学习网-学习教育资源分享平台
R1#sh ip bgp?????? TS668学习网-学习教育资源分享平台
BGP table version is 45, local router ID is 1.1.1.1TS668学习网-学习教育资源分享平台
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,TS668学习网-学习教育资源分享平台
????????????? r RIB-failure, S StaleTS668学习网-学习教育资源分享平台
Origin codes: i - IGP, e - EGP, ? - incomplete
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 23.75.18.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.19.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.20.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.21.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.22.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.23.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.24.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.25.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.26.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
(略去4.4.4.4发布的路由条目)TS668学习网-学习教育资源分享平台
已经把AS65001过滤了
TS668学习网-学习教育资源分享平台
2,使用distribute-list 进行路由过滤TS668学习网-学习教育资源分享平台
To filter all routes, except for routes to the prefix 23.75.0.0/16, you create an access list specifying the 23.75.0.0/16 network prefix and use that access list with a distribute list to filter all incoming routes
R1TS668学习网-学习教育资源分享平台
access-list 1 permit 23.75.0.0 0.0.255.255TS668学习网-学习教育资源分享平台
router bgp 1TS668学习网-学习教育资源分享平台
distribute-list 1 in
R1上BGP表TS668学习网-学习教育资源分享平台
R1(config-router)#do clear ip bgp * s??????????????? TS668学习网-学习教育资源分享平台
R1(config-router)#do sh ip bgp?????????????????????? TS668学习网-学习教育资源分享平台
BGP table version is 80, local router ID is 1.1.1.1TS668学习网-学习教育资源分享平台
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,TS668学习网-学习教育资源分享平台
????????????? r RIB-failure, S StaleTS668学习网-学习教育资源分享平台
Origin codes: i - IGP, e - EGP, ? - incomplete
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 23.75.18.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.19.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.20.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.21.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.22.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.23.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.24.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.25.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.26.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
已经过滤掉189.168.0.0/16网段的路由条目
?也可以使用neighbor命令来过滤路由条目TS668学习网-学习教育资源分享平台
R1TS668学习网-学习教育资源分享平台
access-list 2 permit 189.168.56.0 0.0.1.255TS668学习网-学习教育资源分享平台
access-list 2 permit 189.168.58.0 0.0.1.255 TS668学习网-学习教育资源分享平台
router bgp 1TS668学习网-学习教育资源分享平台
nei 4.4.4.4 distribute-list 2 in
TS668学习网-学习教育资源分享平台
end
R1上BGP表状态TS668学习网-学习教育资源分享平台
R1(config-router)#do clear ip bgp * sTS668学习网-学习教育资源分享平台
R1(config-router)#do sh ip bgpTS668学习网-学习教育资源分享平台
BGP table version is 82, local router ID is 1.1.1.1TS668学习网-学习教育资源分享平台
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,TS668学习网-学习教育资源分享平台
????????????? r RIB-failure, S StaleTS668学习网-学习教育资源分享平台
Origin codes: i - IGP, e - EGP, ? - incomplete
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 20.1.1.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.2.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.3.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.4.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.5.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.18.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.19.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.20.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.21.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.22.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.23.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.24.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.25.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 23.75.26.0/24??? 2.2.2.2??????????????????????????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 189.168.56.0/23? 4.4.4.4????????????????? 0???????????? 0 654 iTS668学习网-学习教育资源分享平台
*> 189.168.58.0/23? 4.4.4.4????????????????? 0???????????? 0 654 i
TS668学习网-学习教育资源分享平台
3,使用prefix-list进行路由过滤TS668学习网-学习教育资源分享平台
在R2上做路由过滤,发送20.1.1.0/24网段到R1TS668学习网-学习教育资源分享平台
R2TS668学习网-学习教育资源分享平台
ip prefix FILTER seq 10 permit 20.1.0.0/16 le 23TS668学习网-学习教育资源分享平台
router bgp 11151 TS668学习网-学习教育资源分享平台
nei 1.1.1.1 prefix-list FILTER outTS668学习网-学习教育资源分享平台
end
R1上BGP表状态TS668学习网-学习教育资源分享平台
R1(config)#do clear ip bgp * sTS668学习网-学习教育资源分享平台
R1(config)#do sh ip bgpTS668学习网-学习教育资源分享平台
BGP table version is 188, local router ID is 1.1.1.1TS668学习网-学习教育资源分享平台
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,TS668学习网-学习教育资源分享平台
????????????? r RIB-failure, S StaleTS668学习网-学习教育资源分享平台
Origin codes: i - IGP, e - EGP, ? - incomplete
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 20.1.1.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.2.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.3.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.4.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
*> 20.1.5.0/24????? 2.2.2.2????????????????? 0???????????? 0 11151 iTS668学习网-学习教育资源分享平台
(略去4.4.4.4发布的路由条目)
TS668学习网-学习教育资源分享平台
4,使用route-map进行路由过滤TS668学习网-学习教育资源分享平台
在R1上做路由过滤,只发送189.168.56.0/23,189.168.68.0/23,189.168.86.0/23网段到R2TS668学习网-学习教育资源分享平台
R1TS668学习网-学习教育资源分享平台
access-list 1 permit 189.168.56.0 0.0.1.255TS668学习网-学习教育资源分享平台
access-list 1 permit 189.168.68.0 0.0.1.255TS668学习网-学习教育资源分享平台
access-list 1 permit 189.168.86.0 0.0.1.255TS668学习网-学习教育资源分享平台
route-map FILTER permit 10TS668学习网-学习教育资源分享平台
match ip ad 1TS668学习网-学习教育资源分享平台
router bgp 1TS668学习网-学习教育资源分享平台
nei 2.2.2.2 route-map FILTER outTS668学习网-学习教育资源分享平台
end
在做路由过滤前,R2上BGP表的状态TS668学习网-学习教育资源分享平台
R2#sh ip bgpTS668学习网-学习教育资源分享平台
BGP table version is 168, local router ID is 2.2.2.2TS668学习网-学习教育资源分享平台
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,TS668学习网-学习教育资源分享平台
????????????? r RIB-failure, S StaleTS668学习网-学习教育资源分享平台
Origin codes: i - IGP, e - EGP, ? - incomplete
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 20.1.1.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 20.1.2.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 20.1.3.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 20.1.4.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 20.1.5.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 23.75.18.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.19.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.20.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.21.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.22.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.23.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.24.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.25.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.26.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 189.168.56.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.58.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.60.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 189.168.62.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.64.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.66.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.68.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.70.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.72.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.74.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.76.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.78.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.80.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.82.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.84.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.86.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.88.0/23? 1.1.1.1??????????????????????????????? 0 1 654 i
做路由过滤后,R2上BGP表状态TS668学习网-学习教育资源分享平台
R2#clear ip bgp * sTS668学习网-学习教育资源分享平台
R2#sh ip bgpTS668学习网-学习教育资源分享平台
BGP table version is 182, local router ID is 2.2.2.2TS668学习网-学习教育资源分享平台
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,TS668学习网-学习教育资源分享平台
????????????? r RIB-failure, S StaleTS668学习网-学习教育资源分享平台
Origin codes: i - IGP, e - EGP, ? - incomplete
?? Network????????? Next Hop??????????? Metric LocPrf Weight PathTS668学习网-学习教育资源分享平台
*> 20.1.1.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 20.1.2.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 20.1.3.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 20.1.4.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 20.1.5.0/24????? 0.0.0.0????????????????? 0???????? 32768 iTS668学习网-学习教育资源分享平台
*> 23.75.18.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.19.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.20.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.21.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.22.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.23.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.24.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.25.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 23.75.26.0/24??? 3.3.3.3????????????????? 0???????????? 0 65001 iTS668学习网-学习教育资源分享平台
*> 189.168.56.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.68.0/23? 1.1.1.1??????????????????????????????? 0 1 654 iTS668学习网-学习教育资源分享平台
*> 189.168.86.0/23? 1.1.1.1??????????????????????????????? 0 1 654 i
TS668学习网-学习教育资源分享平台
只有允许的路由条目发送到R2
route-map的功能十分强大,而且使用方法也十分灵活;不但可以做路由过滤,还可以做路由策略。在前面所讲的BGP路由汇聚中也用到过。关于route-map的使用方法,后续关于BGP的文章会陆续讲到。版权声明:原创作品,谢绝转载。否则将追究法律责任

本站所有资源均来自于68学习网蜘蛛爬取结果,如您发现侵权、违法、存在不和谐内容,告知本站一律删除

本站不以盈利为目的,全站资源仅供学习爱好使用。本站站长邮箱:luo689up@foxmail.com

备案号:闽ICP备15018334号-2

©68学习网  2016-2017版权所有     站点地图

回到顶部